• systemd issues

    From Kyonshi@VERT to alt.bbs.synchronet on Sun Jan 28 21:43:05 2024
    From Newsgroup: alt.bbs.synchronet

    I am trying to get sbbs running as a systemd daemon, but for some reason
    the manual on the wiki does not seem to work.
    I copied this into the override file (this is from https://gitlab.synchro.net/main/sbbs/-/raw/master/install/systemd/sbbs.service as linked from the wiki):

    [Unit]
    Description=Synchronet BBS
    Documentation=http://wiki.synchro.net/
    After=syslog.target network-online.target

    [Service]
    Type=forking
    NotifyAccess=all
    Environment=SBBSCTRL=/sbbs/ctrl
    User=sbbs
    Group=sbbs
    AmbientCapabilities=CAP_NET_BIND_SERVICE
    ExecStart=/sbbs/exec/sbbs d
    ExecReload=/bin/kill -HUP $MAINPID
    Restart=on-failure
    RestartSec=30
    LimitNOFILE=10000

    [Install]
    WantedBy=multi-user.target

    but no matter what I do I get the following answer back when reloading
    the daemon and checking it:

    sbbs@erebor:~ $ systemctl status sbbs
    Warning: The unit file, source configuration file or drop-ins of
    sbbs.service changed on disk. Run 'systemctl daemon-re>
    Ę sbbs.service - Synchronet BBS
    Loaded: bad-setting (Reason: Unit sbbs.service has a bad unit file setting.)
    Drop-In: /etc/systemd/system/sbbs.service.d
    └─override.conf
    Active: inactive (dead)
    Docs: http://wiki.synchro.net/
    http://wiki.synchro.net/

    does anyone know what to do in this case?
    --- Synchronet 3.20a-Linux NewsLink 1.114
    ■ Synchronet ■ Vertrauen ■ Home of Synchronet ■ [vert/cvs/bbs].synchro.net
  • From Digital Man@VERT to Kyonshi on Sun Jan 28 14:17:09 2024
    Re: systemd issues
    By: Kyonshi to alt.bbs.synchronet on Sun Jan 28 2024 09:43 pm

    From Newsgroup: alt.bbs.synchronet

    I am trying to get sbbs running as a systemd daemon, but for some reason
    the manual on the wiki does not seem to work.
    I copied this into the override file (this is from https://gitlab.synchro.ne t/main/sbbs/-/raw/master/install/systemd/sbbs.service as linked from the wiki):

    That sounds incorrect. THe override file is for any *changes* you want from the default contents of the service/unit file (sbbs.service).

    but no matter what I do I get the following answer back when reloading
    the daemon and checking it:

    sbbs@erebor:~ $ systemctl status sbbs
    Warning: The unit file, source configuration file or drop-ins of sbbs.service changed on disk. Run 'systemctl daemon-re>
    Ę sbbs.service - Synchronet BBS
    Loaded: bad-setting (Reason: Unit sbbs.service has a bad unit file setting.)
    Drop-In: /etc/systemd/system/sbbs.service.d
    └─override.conf
    Active: inactive (dead)
    Docs: http://wiki.synchro.net/
    http://wiki.synchro.net/

    does anyone know what to do in this case?

    Delete the override file.
    --
    digital man (rob)

    Synchronet "Real Fact" #27:
    Rob Swindell (digital man) was born approximately 4 hours before the Unix epoch Norco, CA WX: 80.8°F, 22.0% humidity, 0 mph S wind, 0.00 inches rain/24hrs
    ---
    ■ Synchronet ■ Vertrauen ■ Home of Synchronet ■ [vert/cvs/bbs].synchro.net
  • From Kyonshi@VERT to alt.bbs.synchronet on Sun Jan 28 23:56:31 2024
    From Newsgroup: alt.bbs.synchronet

    On 1/28/2024 11:17 PM, Digital Man wrote:
    To: Kyonshi
    Re: systemd issues
    By: Kyonshi to alt.bbs.synchronet on Sun Jan 28 2024 09:43 pm

    > From Newsgroup: alt.bbs.synchronet
    >
    > I am trying to get sbbs running as a systemd daemon, but for some reason
    > the manual on the wiki does not seem to work.
    > I copied this into the override file (this is from https://gitlab.synchro.ne
    > t/main/sbbs/-/raw/master/install/systemd/sbbs.service as linked from the
    > wiki):

    That sounds incorrect. THe override file is for any *changes* you want from the default contents of the service/unit file (sbbs.service).

    > but no matter what I do I get the following answer back when reloading
    > the daemon and checking it:
    >
    > sbbs@erebor:~ $ systemctl status sbbs
    > Warning: The unit file, source configuration file or drop-ins of
    > sbbs.service changed on disk. Run 'systemctl daemon-re>
    > Ę sbbs.service - Synchronet BBS
    > Loaded: bad-setting (Reason: Unit sbbs.service has a bad unit file
    > setting.)
    > Drop-In: /etc/systemd/system/sbbs.service.d
    > ĘĘoverride.conf
    > Active: inactive (dead)
    > Docs: http://wiki.synchro.net/
    > http://wiki.synchro.net/
    >
    > does anyone know what to do in this case?

    Delete the override file.

    Ok, I misread the wiki page completely. Now it works.
    --- Synchronet 3.20a-Linux NewsLink 1.114
    ■ Synchronet ■ Vertrauen ■ Home of Synchronet ■ [vert/cvs/bbs].synchro.net